在低端路由器上实现双机热备份和EIGRP的路由调整

文章出处:Linux 宝库 作者:linux宝库 发布时间:2007-03-12

  这是实际的一个案例:
  
  1. HSRP的配置:
  在LongQuan-Backup(1601)上:
  int e0
  ip address 22.97.80.253 255.255.255.0 secondary
  ip address 21.97.80.253 255.255.255.0
  no ip redirects
  no logging event subif-link-status
  standby priority 200
  standby preempt
  standby ip 21.97.80.1
  standby ip 22.97.80.1 secondary
  standby track Serial0 100/如果S0口的线路当掉了,该E口的优先权减小100,从而成为STANDBY状态
  
  在LongQuan(2501)上:
  int e0
  ip address 22.97.80.254 255.255.255.0 secondary
  ip address 21.97.80.254 255.255.255.0
  no ip redirects
  no ip directed-broadcast
  standby priority 150
  standby preempt
  standby ip 21.97.80.1
  standby ip 22.97.80.1 secondary
  
  
  
  2.LongQuan(2500)上路由的调整:
  interface Serial1.16 point-to-point
  description --- 256K LianTong FR ---
  ip address 22.96.229.2 255.255.255.252
  ip accounting output-packets
  bandwidth 1000000/调高接口带宽
  frame-relay interface-dlci 16
  
  router eigrp 1
  redistribute connected
  redistribute sta
  network 21.0.0.0
  network 22.0.0.0
  distribute-list 22 out Ethernet0/过滤掉21的低METRIC值EIGRP路由
  no auto-summary
  !
  access-list 22 permit 22.0.0.0 0.255.255.255
  
  
  说明:平时正常时候,1601是局域网内两个网段的ACTIVE网关,局域网中目的地址为22网段的数据走联通线路,21网段的走电信线路;当1601的S口DOWN后,25成为主网关,一切数据都走联通线路
  
  FW: 我认为可以建立2 个 hsrp组,让source 21 走1600 ,让source 22 走25,
  在LongQuan-Backup(1601)上:
  int e0
  ip address 22.97.80.253 255.255.255.0 secondary
  ip address 21.97.80.253 255.255.255.0
  no ip redirects
  no logging event subif-link-status
  standby1 ip 21.97.80.1
  standby 1 priority 110
  standby1 preempt
  
  standby 2 ip 22.97.80.1
  standby 2 priority 109
  standby 2 preempt
  
  standby 11track Serial0
  
  standby 2 1track Serial0
  如果S0口的线路当掉了,该E口的优先权减小,从而成为STANDBY状态
  
  在LongQuan(2501)上:
  int e0
  ip address 22.97.80.254 255.255.255.0 secondary
  ip address 21.97.80.254 255.255.255.0
  no ip redirects
  no ip directed-broadcast
  standby priority 150
  
  standby 1 ip 21.97.80.1
  standby 1 priority 109
  standby1 preempt
  
  standby 2 ip 22.97.80.1
  standby 2 priority 110
  standby 2 preempt
  
  standby 11track Serial0
  standby 21track Serial0
  
  我认为不必再2500 上作路由matric 和 distribute-list 调整,以为对pc 来说,认为只有一台router, 数据包往那个router 发,有hsrp protocol 控制 。
  
  FW:希望进一步讨论有什么其他方法达到设计要求。
  
  我的想法:
  如果用3550 代替hub ,现在3550上实现3层交换,
  1600 和 2500 分别接 fa 0/1 fa 0/2
  3550 配置如下 :
  interface FastEthernet0/1
  description link 1600
  
  interface FastEthernet0/2
  description link 2500
  
  int vlan 1
  ip address 22.97.80.100 255.255.255.0 //3550 ip 地址
  
  int vlan 21
  ip address 21.97.80.100 // oa 网段网关
  
  在3550 上实现policy-router 让yewu 和 oa 数据分别走路径,并实现2条路经;互为备份?
  不知道想法可不可行?